Wednesday, April 18, 2012

“Reset all Document IDs in this Site Collection to begin with these characters” does not seem to work on 2010 SP1 + June CU

SharePoint 2010 has introduced an excellent out-of-the-box feature that allows you to automatically assign a unique document ID to all of your documents that are uploaded to your SharePoint site. This site-collection scoped feature is designed the document IDs are guaranteed to be unique across the site collection that the feature has been activated for. The major use case to use this feature is all document ID on one site collection can have a common prefix and we could have a short URL to access the documents. One example to access the document is http://sbx01/sites/harry/_layouts/DocIdRedir.aspx?ID=ZHMD6RZVPS52-3-2.

This seems like an excellent feature if the uniqueness is true. However, the issue is there are several bugs on 2010 SP1 + June CU and the IDs are not guaranteed to be unique. You could reproduce the duplicated document ID issues through save template or content organizer. We are upgrading to 2012 Feb CU that supposed to fix the duplicated IDs issue. There is no surprise that it does not fix the existing duplicated document IDs. The major reason is “Reset all Document IDs in this Site Collection to begin with these characters” failed on several environment after Feb CU upgrade. We have several people reported similar issues.

Here is the procedure to reproduce the issue.

1. Active “Document ID Service” site collection feature
2. Add column “Document ID” to the list library
3. Add item and you will see Document IDs 

4. Reset all Document IDs in this Site Collection to begin with these characters” from Set Actions->Site Settings->Site Collection Adminstration->Document ID settings

5. Run two timer jobs named “DocumentID enable/disable job” and “Document ID assignment job” for the webapp
6. De-active/Active “Document ID Service” site collection feature
7. Column “Document ID” values on the list libraries not updated
8. New list may not have “Document ID” assigned

Our original thought is to remove and reset the document ID on the site with duplicated IDs, then regenerate the IDs for all the document on 2012 Feb CU. This way it should have all unique IDs. Since this is not working as we expected, we are not able to fix the existing duplicated document IDs. If anyone find any workaround or solution, please let us know.

Thanks.


No comments:

Post a Comment